From: matz@... (Yukihiro Matsumoto) Date: 1998-02-20T15:53:54+09:00 Subject: [ruby-list:6570] Re: rgrep (Re: call for scripts) まつもと ゆきひろです In message "[ruby-list:6567] Re: rgrep (Re: call for scripts)" on 98/02/20, toyofuku@juice.or.jp writes: | 豊福@パパイヤです。 |> while line = $gets.call(file) | | 一瞬オブジェクトとメソッドの位置が逆?と妙な気分に |なりました。 | | $gets = proc { レシーバー.gets } | while line = file.some_method($gets) | |みたいな書き方ってないのでしょうか。 オブジェクト指向的な意味づけがちゃんとできれば良いのですが, 一般的にはできないような気がしますねえ. | 普段 "." と ".." は使うことが少ないような気がする |ので Dir.foreach の引数増やして | | Dir.foreach(path, pochi_and_pochipochi = 0) | |ってのはどうですか。 そういう場合にはやっぱり Dir["*"] でしょう. Dir.glob("*") でもいいけど. まつもと ゆきひろ /:|)