From: ARAI Shunichi Date: 2007-07-20T12:25:20+09:00 Subject: [ruby-list:43750] Re: Hash.mergeはなぜHash.+ではないの? お返事ありがとうございます。 > 可換でないという点では文字列の+も可換ではないんですが、こっ > ちは単純な連結(どちらの情報もなくならない)ので妥協してます。 > 以前には「+じゃなくて*を使おう」と提案した人もいますが。 > > Hashの場合は可換でないだけでなく情報も減る(可能性がある)ので。 なるほど、そういうわけだったのですね。 実用上はあると便利だと思うのですが、 違和感があるのもわかります。 何か2項演算子にマップされていると便利なんですが、 +以外にあまりピンとくるものもないですね。 せいぜい|くらいでしょうか。 ----- Mellowtone Inc. - life is a melody Shunichi Arai http://www.mellowtone.co.jp ----- Original Message ----- From: "Yukihiro Matsumoto" To: "ruby mailing list" Sent: Thursday, July 19, 2007 5:32 PM Subject: [ruby-list:43749] Re: Hash.mergeはなぜHash.+ではないの? > まつもと ゆきひろです > > In message "Re: [ruby-list:43748] Re: Hash.mergeはなぜHash.+ではないの?" > on Thu, 19 Jul 2007 17:17:30 +0900, Urabe Shyouhei > writes: > > |ARAI Shunichi wrote: > |> +に割り当てられていると結構便利で気持ちよい気がするんですが、 > |> どないなもんでしょう? > |以前から思っているのですが可換でない演算に+という名前を付 > |けるのは相当に違和感があります。 > > 可換でないという点では文字列の+も可換ではないんですが、こっ > ちは単純な連結(どちらの情報もなくならない)ので妥協してます。 > 以前には「+じゃなくて*を使おう」と提案した人もいますが。 > > Hashの場合は可換でないだけでなく情報も減る(可能性がある)ので。 >