From: take_tk Date: 2005-10-24T19:15:59+09:00 Subject: [ruby-list:41358] Re: Date へのメソッド追加要望 たけ(tk)です [ruby-list:41357] Re: Date へのメソッド追加要望 にて URABE Shyouhei さん曰く: > あと set_date という名前がかなり嫌いです。Date のインスタンスは > immutable であるべきです。 これだけ同感。あとは、感覚がよくわからぬです。 raigetu_25niti = Date.today.inc_month(1).set_day(25) と d = Date.today >> 1 ; raigetsu_25niti = Date.new(d.year, d.month, 25) で便利さや分かりやすさが変らないという感覚が分からぬデス。 ---- inc や set だと mutable なイメージになるなら、 > >raigetu_25niti = Date.today.inc_month(1).set_day(25) > ># 今日から見て 1ヶ月後の 25日 raigetu_25niti = Date.today.add_month(1).dup_with_day(25) とか raigetu_25niti = Date.today.add(nil,1).dup(nil,nil,25) Take_tk = KUMAGAI Hidetake たけ(tk)=熊谷秀武