From: matz@... (Yukihiro Matsumoto) Date: 1997-08-27T14:33:44+09:00 Subject: [ruby-list:3854] Re: SyslogSendmail class まつもと ゆきひろです In message "[ruby-list:3852] Re: SyslogSendmail class" on 97/08/27, 石塚圭樹 writes: |けいじゅ@日本ラショナルソフトウェアです. |やはり, | | attr [:date, TRUE], [:time], [:process_name, TRUE] | |ですかねえ? むむむ….それよりは attr :date, :time, :process_name, TRUE の方がまだましですねえ. |>というのはですね.attrはメソッドがすでに定義されているとなに |>もしない(改めて再定義しない)んですが,idというメソッド(オブ |>ジェクトIDを返す)がすでに存在しているからですね.これは上 |>書きした方が良いでしょう,仕様を変えましょう. | |仕様? バグに限りなく近いと思うんですけど... そうでもないんです.たとえば def foo do_something @foo end attr :foo とした場合にfooを再定義しちゃまずいでしょ. 今後は「そのクラスで」メソッドが定義されていなければ再定義と 言う仕様でどうでしょう. |># でもやっぱりidは名前を変えた方が良いかも. | |変えた方がいいような気もしますが... 結構使っているからなあ... 変える場 |合でも, とりあえず, idはaliasで残して頂いてもらうと嬉しいなぁ. これは高木さんのプログラムで id を名前を変えた方が良いかも, というつもりだったんです.Object#idを変えるつもりは無いです. まつもと ゆきひろ /:|)