From: m_seki@... Date: 2002-03-12T12:57:39+09:00 Subject: [ruby-list:34356] Re: erb-1.4.0 咳といいます。 > > * erbu.rb > > * uメソッドの追加 > > このuとhというメソッドなんですが、体を現す本名を用意して、 > hとuはそれへのaliasにするのはどうでしょう。 ふうむう。 > そしてなひとしては略称を使わないことを推奨していきたい。 > <%= html_eacape( ... ) %> > が見辛い(?)という意見はわからないでもないんだけど、 > 見易くするためだったら > <%=h ... %> > と書けるようにするより、 > <%={ ... }%> > みたいに構文糖らしく、メソッドじゃなく文法で対応するほうが > いいんじゃないかなー。 eRubyの仕様になっちゃうのでパス。 > # だから要らない、ではなくて、「構文糖っぽく見えないほうがいい」 > # →「hじゃなくてhtml_escape推奨」ということです。 見えるといやなのかぁ。 構文糖のようなメソッドを使いたくて作ったので変えたくないです。 h, uの機能が欲しいのであれば、CGIに同じものが入ってるし。 # 一目でばれるけど、CGIからぱちってきた。 咳の趣味に問題があるのかなぁ。自信ない。roughから削除しちゃおうかな。