From: "NAKAMURA, Hiroshi" Date: 2002-03-12T11:13:01+09:00 Subject: [ruby-list:34350] Re: erb-1.4.0 なひです。 > From: m_seki@mva.biglobe.ne.jp > Sent: Tuesday, March 12, 2002 2:15 AM > * erbu.rb > * def_method/def_module/def_class の追加 > * load_erbメソッドの削除 > * uメソッドの追加 このuとhというメソッドなんですが、体を現す本名を用意して、 hとuはそれへのaliasにするのはどうでしょう。 PS. そしてなひとしては略称を使わないことを推奨していきたい。 <%= html_eacape( ... ) %> が見辛い(?)という意見はわからないでもないんだけど、 見易くするためだったら <%=h ... %> と書けるようにするより、 <%={ ... }%> みたいに構文糖らしく、メソッドじゃなく文法で対応するほうが いいんじゃないかなー。 # だから要らない、ではなくて、「構文糖っぽく見えないほうがいい」 # →「hじゃなくてhtml_escape推奨」ということです。