From: FUJIOKA Takeyuki Date: 2002-03-12T09:54:17+09:00 Subject: [ruby-list:34346] Re: require "cgi/session" でエラー 藤岡です。 At Tue, 12 Mar 2002 00:19:46 +0900, akira yamada wrote: > > > パッケージのことですが,Vine-2.5直前ですが, > > できればVineSeedから下ろしてきて,db1とかの機能を > > 削ったruby-1.6.7が2.1.5のupdateに入ってくれれば一番うれしいですね。 > > 2.1.5のupdateで1.6.7にするというのは多分難しいだろうと思います。 > ただ、そのあたりも含めていろいろと考えたり相談したりしてみます。 > 今日、明日にどうこうというのは無理ですが。 これはポリシーの問題でしょうか? 仕様だったら諦めますが,バグなのでなんとかして欲しいです。 Plusのものだったら私でもputできるのですが, ディストリ本体のものなので私にはなにもできませんし。 > 個人的にVine Linux 2.1.5向けの1.6.7のパッケージなりなんなりを > 用意することは(手間のことはおいとくとすれば)可能だとは思います。 > これも今日、明日にどうこいうといのはできませんけれど。 > 自分で作ってみようと思ったのですが,Seedのruby.specの中を rb_cv_func_strtod=no CFLAGS="${CFLAGS:-%{optflags}}" ./configure \ --prefix='%{rb_prefix}' \ --mandir='%{rb_mandir}' \ --sysconfdir='/etc' \ --localstatedir='/var' \ --with-sitedir='${prefix}/%{rb_site}' \ --with-default-kcode=none # --with-dbm-include=/usr/include/db1 \ # --enable-shared \ # --enable-ipv6 \ # --with-lookup-order-hack=INET \ # %{_target_cpu}-%{_target_os} 上の用にコメントアウトして,BuildRequireからdb1を外したのですが, emacsenがないのでコンパイルが止まります。 Vine-2.1.5はどうせemacsenがないので, ごっそりけずってもいいのでしょうか? ん,もしかして,2.1.5のruby-1.6.2のspecファイルを 参考に作った方がいいかもしれないとか。 ---- 藤岡 岳之/FUJIOKA Takeyuki