From: tadf@... Date: 2002-03-10T11:11:55+09:00 Subject: [ruby-list:34281] Re: newdate ふなばです。 newdate (仮名) のいくつかのメソッド名について、悩みつづけてきましたが、 現時点では、下記のようにしよう、と思っています。 それで、仮に、これでよいとして、今後は、あたらしい名前の使用を奨励すべ きかと思います。当面 (あるいは永久に)、旧来の名称をコードから削除する ことはないと思いますが、添付文書からは、早目に、あるいはすぐに削除する (少なくとも、とくに評判の悪そうなものの見出しは) ことは考えています。 ご意見があれば、お願います。これが最高だというつもりは、まったくないの で、他によさそうなの思いついたら、教えてください。なければ、このままど んどん進めちゃうつもりです。 new1 jd new2 ordinal new3 civil neww commercial newp parse と strptime に分離 exist1? jd? exist2? ordinal? exist3? civil? existw? commercial? newsg new_start sg start newof new_offset of offset nhol? national_holiday? ふなばただよし