From: norio goto Date: 2001-05-30T13:33:30+09:00 Subject: [ruby-list:29886] mod_ruby and eruby 後藤@横河工事です。 以下の環境で eruby の configure オプションによりインストールの不具合 が発生しました。 * Linux version 2.2.17 (herbert@arnor) (gcc version 2.95.2 20000313 (Debian GNU/Linux)) #1 Sun Jun 25 09:24:41 EST 2000 * ruby-1.6.3 * mod_ruby-0.8.1 * eruby-0.9.2 eruby のインストールで ./Makefile --enable-shared --default-charset="EUC-JP" mod_ruby のインストールで ./Makefile --enable-eruby とすると apache の起動で以下のエラーとなります。(途中改行してます) goto@debian:/etc/apache$ sudo /etc/init.d/apache start Starting web server: apache. Syntax error on line 108 of /etc/apache/httpd.conf: Cannot load /usr/lib/apache/1.3/mod_ruby.so into server: liberuby.so.0.9: \ cannot open shared object file: No such file or directory /usr/sbin/apachectl start: httpd could not be started なお、--enable-shared を外してコンパイルすると問題なくインストールされます。 以下は apache の error.log です。 [Wed May 30 12:59:57 2001] [notice] Apache/1.3.9 (Unix) Debian/GNU mod_ssl/2.4.1 0 OpenSSL/0.9.4 mod_ruby/0.8.1 Ruby/1.6.3(2001-03-19) eRuby/0.9.2 configured -- resuming normal operations よって、eruby の --enable-shared オプションは不要と考えてよいのでしょうか。 -- goto@yokogawa-kouji.co.jp