From: "K.Kosako" Date: 2001-05-15T19:11:33+09:00 Subject: [ruby-list:29672] Re: Enumerator Akinori MUSHAさんの<8666f9gyrz.wl@archon.local.idaemons.org>から > 3. enum_with の名前はこれでいいのか? > > → enum, with なども考えられる。ただ、ともに少し意味が曖昧で、 > ジェネリック過ぎる感じがする。これでいいのだ。 enum_withの機能は、Enumeratorオブジェクトを返すことだけですよね? それなら、名前はto_enumのほうが分かり易いように思います。 ---- 小迫@ソフネック 渋谷区恵比寿1-15-1