From: Shin-ichiro HARA Date: 2001-03-23T10:02:08+09:00 Subject: [ruby-list:28917] Re: Numeric.new 原です。 > 抽象クラスに new があった方が承継クラスを実装するときに便利だというこ >とですね。ありがとうございました。 そういうことですね。 ところで、ちょっと話は違う(似てはいる)のですが、Cマガジンにごとけんさん も書いているように Numeric::Zero みたいのがあった方がいいと思います。とい うか、最近数クラスを幾つか書いたうえで、「絶対」あるべきであるという結論に 達しました。考えられるのは、 Numeric::Zero (定数) Numeric::zero (クラスメソッド) Numeric#zero (メソッド) ですが、私は3つともあっていいと思います。もちろん下の2つは Zero から 派生可能なわけですが。 さらに、 Numeric::Unit Numeric.unit Numeric::unit も。unit って名前が気に入らない人もいるかと思うけど。