From: matz@... (Yukihiro Matsumoto) Date: 1997-04-30T00:15:03+09:00 Subject: [ruby-list:2877] Re: [BUG] File.size まつもと ゆきひろです In message "[ruby-list:2874] Re: [BUG] File.size" on 97/04/30, 渡辺博文 writes: | |わたなべです. | |:まつもと ゆきひろです | |:もし,もっとよいアイディアがあれば提案してください. | |さっきのは勘違いしてました. File.size は test(?s, file) の |alias みたいなもんなんですね. だから同じ仕様じゃないとまずい. いまはaliasになっていますが,べつにそうである必要はないと思っ ています.ですから,当初のわたなべ案を採用するつもりです. んで,test(?s, file)のaliasは必要かなあ.他のにはたいてい(全 部?)aliasがあることを考えるとあった方が良いのかも.