From: gotoken@... (GOTO Kentaro) Date: 2000-12-27T22:52:40+09:00 Subject: [ruby-list:26894] Re: cgi.rb and Regexp::last_match ごとけんです In message "[ruby-list:26858] Re: cgi.rb and Regexp::last_match" on 00/12/26, Yukihiro Matsumoto writes: >|String#to_l() : Integer() が例外を返す局面で nil を返す >|String#to_d() : Float() が例外を返す局面で nil を返す >| >|先だっての to_i? to_f? よりはいい名前だと思います。いかがでしょうか。 > >その提案の意図は理解できます。方向性には賛成です。が、to_lや >to_dでは(Rubyにlongやdoubleがない以上)、あまり良い名前でない >ように思います。単に > > (Integer(s) rescue nil) > >で良いような気がするんですけど、そんなにchainしたいんですか? ぼくは、次のように考えています。 * String#to_i は非常によく使うので、わざわざ Integer( ) と 書きたくない。 * to_i が変換できないときに 0 を返すというCのatoi()に対する 互換性(?)への拘りはちょっと理解できない。 * nilを返すことによって得られる恩恵に比べればこれまでの Rubyに対する互換性による恩恵はずっと小さい。 他のひとはどうでしょう? -- gotoken