From: sinara@... Date: 1997-03-13T15:14:57+09:00 Subject: [ruby-list:2369] Re: [Req] Hash#reverse (Re: [Req] Array#reverse ) 原です。 > けいじゅ@SHLジャパンです. > メソッド名としては, inverseのほうがよいのでは?? なるほど確かにそうですね。でも perl では reverse となってる んですよ。 この際、 { 1=>10, 2=>20, 3=>30 }.reverse ==> { 10=>1, 20=>2, 30=>3 } に加えて、 { 1=>10, 2=>10, 3=>30 }.inverse ==> { 10=>[1,2], 30=>[3] } というのも作っちゃうとか、、、。