From: matz@... (Yukihiro Matsumoto) Date: 2000-02-23T08:54:48+09:00 Subject: [ruby-list:20954] Re: Hash#update について まつもと ゆきひろです In message "[ruby-list:20948] Re: Hash#update について" on 00/02/23, 中村暁史 Nakamura Akifumi writes: |Fuyuhiko Maruyama (丸山冬彦) wrote: | |> 現在のHash#update(other)では、HashオブジェクトselfにHashオブジェクト |> otherをマージする機能を提供していますが、このマージの際に、selfとother |> の両方に同じキーのエントリがある場合、otherの方の値で上書きすることに |> なっています。この動作を変更し、同じキーのエントリがあった場合には |> updateに与えられたブロックでどちらの値を選択するか決められるようにしま |> せんか? | |それって、updateとは違う名前にするほうが |すっきりするなーと思ったです。 |選択といっても、selfのほうの値を選択する時ってのはつまり |update「しない」ことになるわけですよね。 私も同じ意見です。 |#やっぱり名前は大事だ… 私も同じ意見です。:-)