From: "中村暁史 Nakamura Akifumi" Date: 2000-02-23T03:01:25+09:00 Subject: [ruby-list:20948] Re: Hash#update について お世話になっております。 A.中村です。 On Wed, 23 Feb 2000 00:27:15 +0900 Fuyuhiko Maruyama (丸山冬彦) wrote: > 現在のHash#update(other)では、HashオブジェクトselfにHashオブジェクト > otherをマージする機能を提供していますが、このマージの際に、selfとother > の両方に同じキーのエントリがある場合、otherの方の値で上書きすることに > なっています。この動作を変更し、同じキーのエントリがあった場合には > updateに与えられたブロックでどちらの値を選択するか決められるようにしま > せんか? それって、updateとは違う名前にするほうが すっきりするなーと思ったです。 選択といっても、selfのほうの値を選択する時ってのはつまり update「しない」ことになるわけですよね。 updateって一律全部updateしちゃうからupdateっていう (日本語になってないぞ俺)ようなきがします。 #やっぱり名前は大事だ…