From: "H.TAKEI" Date: 2000-02-21T19:29:38+09:00 Subject: [ruby-list:20892] Re: collect + find_all ==> select ? 武井です。 > まつもと ゆきひろです > というわけで、Enumerableクラスに「nil以外の要素を集める」と > いうメソッドを追加することに反対ではないです。しかし、その名 > 前はcompactであるべきではないということですね。 一応,名前の案を書いておきます。 名前案     機能 ===================================== map_v collect (w/o block)  to_a map_x select (w/o block) Array#compact map_vx collect.compact > |> |★ "集合"をあつかうクラスはないのでしょうか? > |> > |> 私は大体は配列で済ましてしまいます。& とか | とかはその辺を > |> 意識したメソッドです。足りないメソッドがあれば追加しても良い > |> とは思います。 > | > |必要ありそうな候補は, > | > |・集合として同じか? > |・部分集合か? > | > |ぐらいが思いつきます。 > > ふむ。それってどういう定義が望ましいですか? > > ちょっと考えると任意の要素の集合として考えるとき、要素につい > ての前提をなにも使えなければ、全ての組合せで比較するしかない > ように感じられますが。また、比較の基準はなににしましょう。 > ==? ===? equal? > > 要素がComparableであればあらかじめsortするという手が使えます > けどねえ。 集合の要素は比較可能が前提でいい気がします。 (STLもそのようですし。) 比較基準は,必要ならカスタマイズできるとうれしいかも。 Set.new {|a,b| ... } とか。 #いまさらですが,本屋でruby本を立ち読みして,  『おぉ!』と感動して以来,まつもとさんのファンでした。  今回このように議論していただき,大ファンになりました。(^^;  陰ながら応援&布教活動に励んでおります。 -- takei.hideaki@lab.ntt.co.jp