From: "H.TAKEI" Date: 2000-02-21T12:23:54+09:00 Subject: [ruby-list:20883] Re: collect + find_all ==> select ? 武井です > まつもと ゆきひろです > ブロック値を > 使わない 加工値として 条件値として > to_a collect select > もっとも、名前重視のまつもとですから、このメソッドを表すのに > これ以上無いって名前が出てくれば、考えも変わる可能性が高いで > すが。 せっかくですので,collect.compactによさそうな 名前を考えてみました。 案1)"colpact"  う〜む,苦しいか。(^^; 案2)この際,いろいろ名前つけちゃう 名前案     現状 ===================================== map_v collect to_a (ブロックなし) map_x select map_vx collect.compact map は lisp の mapcar などの例からとってみました。 v は value,x は exist からとってみました。 #この辺はもっとセンスいいのがある気も。。 付け加える名前が多すぎて嫌な場合は, map("vx") とかにしてもいいのかも。 -- takei.hideaki@lab.ntt.co.jp