From: nobu.nakada@... Date: 1999-10-17T13:48:42+09:00 Subject: [ruby-list:17770] Re: <=> なかだです。 At Sat, 16 Oct 1999 22:20:39 +0900, Shin-ichiro Hara wrote: > 話はちょっと変わるけど、non という演算子を用意して x.nonzero? を > x non 0 と書けるとどうでしょう?左辺が右辺に等しければ false そう > でなければ左辺。 メソッドではなくて演算子というのは優先順位の問題からでしょうか。 > x non 0 non "" > > とフィルタみたいに書けるのはいいな。 これは面白いと思いますが、これなら Kernel#non でも十分では。 module Kernel def non(it) self != it and self end end -- そうだ 強気に ちょっと インチキに☆彡 中田 "Bugるくらいがちょうどいいかも;-)" 伸悦