From: EGUCHI Osamu Date: 1999-10-12T22:10:28+09:00 Subject: [ruby-list:17643] Re: <=> (Re: Hash $B$K(Bnil$BCM$rF~$l$?$J$i(B) えぐち@エスアンドイー です。 >>> In message Re: [ruby-list:17641] Re: <=> (Re: Hash $B$K(Bnil$BCM$rF~$l$?$J$i(B) On Tue, 12 Oct 1999 21:54:59 +0900, えぐち said: えぐち> えぐち@エスアンドイー です。 えぐち> えぐち> >>> In message [ruby-list:17641] Re: <=> (Re: Hash $B$K(Bnil$BCM$rF~$l$?$J$i(B) えぐち> On Tue, 12 Oct 1999 21:42:08 +0900, Tadayoshi Funaba said: えぐち> えぐち> tadf> ふなばです。 ... えぐち> tadf> 僕も <=> の仕様変更はムリがあるように思います。で、これだけなら、 えぐち> tadf> えぐち> tadf> (a.to_i <=> b.to_i).nonzero? || a.to_s <=> b.to_s えぐち> tadf> えぐち> tadf> でもよさそうなので、あたらしい演算子を導入する理由も、少し弱い気がしま えぐち> tadf> すです。 えぐち> えぐち> ですが、これだと nonzero? が -1/false/+1 でなく true/false/true えぐち> を返して芳しくないですね。 面目無い、なにかと勘違いしてました。 nonzero? は正しく、 -1/nil/+1 でした。 _o_ えぐち