From: "NAKAMURA, Hiroshi" Date: 1999-09-06T19:35:13+09:00 Subject: [ruby-list:16523] Re: cgi.rb なひです. > From: Yukihiro Matsumoto [mailto:matz@netlab.co.jp] > Sent: Monday, September 06, 1999 6:38 PM > べきだと思っています。が、メソッドなんだから意味を付加しても > 良いじゃないかと思うわけです。つまり、content_lengthはlength > なんだから整数にしてやるとか。 | From: Yukihiro Matsumoto [mailto:matz@netlab.co.jp] | Sent: Monday, September 06, 1999 6:38 PM | 捉え方の問題だと思いますが、数を提供すべきメソッドが数でなく、 | 数字を提供するのはおかしいと思います。新たなヘッダを導入する | と言うことはライブラリに機能を追加するわけですから、ちゃんと | 判断して設計すべきだと思います。 全くその通りだと思います.「何も考えずに一様にString」案は 取り下げます.混乱させてすいません. / / / とすると,「何も考えずに一様にArray」も,考えたほうがいいのかな... とはいえ,「複数になりうるものがArrayになる」ってのは悪くない... うん,やっぱり,一様にArrayの方はこれで良さそうな気がします.(^-^