From: matz@... (Yukihiro Matsumoto) Date: 1999-09-06T18:37:57+09:00 Subject: [ruby-list:16517] Re: cgi.rb まつもと ゆきひろです In message "[ruby-list:16454] Re: cgi.rb" on 99/09/03, "NAKAMURA, Hiroshi" writes: |> 追加。content_length, server_port は多くの場合数値として使われると思わ |> れるので、Integer(ENV["CONTENT_LENGTH"]) のようにするという提案もあり |> ますが、いかがでしょうか? 文字列として使いたい場合には to_s 等とする |> 事にはなりますが。 | |なひはStringのままでいいと思います.今後新たなヘッダが増えるたびに, |数値のみフィールドかどうか判断して追加していくの, |cgi.rb側としては大変じゃないでしょうか... 捉え方の問題だと思いますが、数を提供すべきメソッドが数でなく、 数字を提供するのはおかしいと思います。新たなヘッダを導入する と言うことはライブラリに機能を追加するわけですから、ちゃんと 判断して設計すべきだと思います。