From: matz@... (Yukihiro Matsumoto) Date: 1999-08-06T15:46:50+09:00 Subject: [ruby-list:15926] Re: Windows95 で Tk まつもと ゆきひろです In message "[ruby-list:15910] Re: Windows95 で Tk" on 99/08/06, GOTO Kentaro writes: |反応が遅れたらもう変更されてしまった ^^;; より厳しいチェック |を望んだ張本人のひとりです。 | |確かに互換性は考慮すべきですが、個人的には、この変更はよくな |いと思います。例の件に関して言うと、 | |tools.each {|klass, *keys| | |のような書き方が好ましい気がします。というのは、ブロック変数 |は代入との対称性よりも、メソッド定義との対称性の方が自然に思 |えるからです。 私も前橋さんのおっしゃるようにブロックパラメータは代入(多重 代入)との類似性の方が強いと思います。 ブロックをMLのlambdaのようにとらえるとごとけんさんの視点の方 が自然なんでしょうけど、実態はそうではありませんよね。どーで も良いことですが、歴史的にもそうではありません。 まつもと ゆきひろ /:|)