From: nobu.nakada@... Date: 1999-07-01T23:50:15+09:00 Subject: [ruby-list:15181] Re: undefined method `-@' for Fixnum (NameError) なかだです。 At Thu, 1 Jul 1999 14:18:19 +0900, Akira Endo wrote: > > obj.inspect だけではなくて obj.type.inspect `obj.inspect' を出力するよ > > うにした方が分かりやすいのではと思いますが、どうでしょうか? > > ご提案は,undefined method `-@' for Class `Fixnum' でしょうか? はい、そういう感じです。 > Fixnumと出てきてしまうのが情報過多のような気もします.for Class > でとめてしまった方が,さて何だろう,と考えるのにはいいかも > しれません.Fixnumと言われてしまうと,あれっと思ってしまう > でしょうから,むしろ多少分かりにくいエラーメッセージの方が > 親切かも. 「さて何だろう」と考えるのはいいんですが、何がレシーバなのか分かったほ うが debug しやすいように思うんですが。 -- ♪だって だって だって だって Bugってるんだもん!♪ 中田 "ねぇ hoge ってして♪" 伸悦