From: Akira Endo Date: 1999-07-01T14:18:19+09:00 Subject: [ruby-list:15176] Re: undefined method `-@' for Fixnum (NameError) 遠藤です. In [ruby-list:15171] Re: undefined method `-@' for Fixnum (NameError) nobu.nakada@nifty.ne.jp wrote: > obj.inspect だけではなくて obj.type.inspect `obj.inspect' を出力するよ > うにした方が分かりやすいのではと思いますが、どうでしょうか? ご提案は,undefined method `-@' for Class `Fixnum' でしょうか? Fixnumと出てきてしまうのが情報過多のような気もします.for Class でとめてしまった方が,さて何だろう,と考えるのにはいいかも しれません.Fixnumと言われてしまうと,あれっと思ってしまう でしょうから,むしろ多少分かりにくいエラーメッセージの方が 親切かも.