From: nagai@... Date: 1999-04-16T11:34:58+09:00 Subject: [ruby-list:13791] Re: iterator 永井@知能.九工大です. # 遅ればせながら,誕生日おめでとうございます.> まつもとさん From: matz@netlab.co.jp (Yukihiro Matsumoto) Subject: [ruby-list:13751] Re: iterator Date: Thu, 15 Apr 1999 12:13:13 +0900 Message-ID: matz> | これからはブロック付メソッドと呼ぼうかな。 matz> この呼び方は歓迎です.リファレンスマニュアルではできるだけ matz> 「イテレータ」と言う言葉はなくそうと考えてます. qsort や gsub などのように,ブロックがなくてもよいし, 受け取ることも可能というものもありますので, 個人的には「ブロック *付* メソッド」というより 「ブロック受理(可能)メソッド」(block-acceptable method) という感じです. From: matz@netlab.co.jp (Yukihiro Matsumoto) Subject: [ruby-list:13756] Re: iterator Date: Thu, 15 Apr 1999 12:52:37 +0900 Message-ID: matz> |iterator? の alias として given_block? なんてのを用意するのも matz> |いいかも知れませんね。 matz> given_block よりは block_given? かなあ. matz> iterator? に別名を用意しようとは昔から考えているので,別名の matz> 案は他にも募集します. 上記のように「受理」で考えると accept_block? とかもありそうですが, 与えられたからといって,受諾するとは限らないのでダメですね.(^_^; この点から考えると,receive_block? だとかのように, receive を使う方が感覚に合いそうです. # 「receive だけど not accept」だとか. -- 永井 秀利 (九工大 知能情報) nagai@ai.kyutech.ac.jp