From: Wakou Aoyama Date: 1999-04-15T13:10:52+09:00 Subject: [ruby-list:13757] Re: iterator 青山です。 Thu, Apr 15, 1999 at 12:52:37PM +0900 において Yukihiro Matsumoto さん曰く: > |iterator? の alias として given_block? なんてのを用意するのも > |いいかも知れませんね。 > > given_block よりは block_given? かなあ. > iterator? に別名を用意しようとは昔から考えているので,別名の > 案は他にも募集します. > > # ま,でも defined? yield で調べられるんだけど. yield も(日本人には?)あまり馴染みがないような感じも。 block_given? だと block_call とか? block_call if block_given? -- 青山 和光 Wakou Aoyama