From: matz@... (Yukihiro Matsumoto) Date: 1999-03-10T11:04:49+09:00 Subject: [ruby-list:12700] Re: alternative name of iterator まつもと ゆきひろです In message "[ruby-list:12696] Re: alternative name of iterator" on 99/03/10, moochan writes: |> aBoolean.ifTrue{ print "true\n" }.ifFalse{ print "false\n" } |> |>くらいならできますよ.効率は現実的じゃないですけどね. | |これは単にカスケーディングで実現できるよ,って話ですね. 記法についていえばそうです.それとも aBoolean.ifTrue(Proc.new{...}, Proc.new{...}) という記法の方がSmalltalkのセマンティックに近いので,お好み ですか? |ただ,非効率になるとおっしゃっているのは,aBoolean が false を |返した場合,直接ifFalseを呼べないからですね. むしろ,ブロックの生成コストを気にしています. |ところで,ifTrueからtrueが返った場合,ifFalseはどんな挙動を示す |のでしょうか? |# まさかエラーじゃないよね. 単に無視でしょう. |# Ruby本にはまつもとさんのプロフィールは載るんでしょうね当然. |# 出版社はアスキーだったんや.オライリではないやろと思ってはいたが. オライリーとも話はしてます. まつもと ゆきひろ /:|)