From: Shugo Maeda Date: 1999-01-31T00:33:51+09:00 Subject: [ruby-list:11829] Re: [patch] Array#delete_if (Re: Array クラス) 前田です。 matz@netlab.co.jp (Yukihiro Matsumoto) writes: > |> > collect > |> > select(->find_all) > |> > detect(->find) > | > |僕もこのaliasはあった方がよいと思います。 > > そうですか.理由がSmalltalkerってのが弱い気がしますが.^^;;; selectは名前的にも好きです。 detectはちょっと堅い感じがしますが。 > 私もSmalltalkerにあったことないですから. あれ、石塚さんは?(^_^; Javaがきっかけで復権したとか聞くのですが、なぜかあまり身近に 使っている人を見ませんね。 # Satherほどではないですけど(^_^; > |> > を用意してたんですけど,injectとか見るにいたって(というのは > |> > 冗談ですが),日本人にはよく分からんとか思ってなくしちゃった > |> > んですよね. > | > |inject:into:がわかりにくいのは名前のせいだけではないという気も > |します(^_^; > > そうなんですよねえ.わかりやすいselect/detect/collectだけで > もaliasを用意しますか. collectはそのままですよね。 rejectはselectで代用できるから別にいらないのかな。 # それを言うならunlessだって同じという反論もあるかもしれませんが。 -- 前田 修吾 (mailto:shugo@netlab.co.jp)