From: matz@... (Yukihiro Matsumoto) Date: 2000-05-24T18:30:37+09:00 Subject: [ruby-dev:9806] rescue variable syntax まつもと ゆきひろです 相談に乗ってください rescueで例外オブジェクトを格納する変数を指定する文法を導入し ようと考えています。 ちょっと前までは rescue RuntimeError in var のような形式にしようと思ってましたが、どうも英語的にヘンだな と思ってたら外人たちにはもっと変に見えたようです。 で、いろいろ考えたあげく残ったのは以下のふたつです。 どっちがよいと思いますか? あるいは別案がありますか? # 新しい予約語を導入する予定はありません。 rescue RuntimeError => var rescue RuntimeError : var うーむ。 まつもと ゆきひろ /:|}