From: nobu.nakada@... Date: 2000-02-23T09:45:17+09:00 Subject: [ruby-dev:9274] Re: ruby object なかだです。 At Wed, 23 Feb 2000 08:54:54 +0900, matz@netlab.co.jp (Yukihiro Matsumoto) wrote: > |> rescue ScriptError => err > |> > |> とかか? うーん。 > | > |rescue|err| ScriptError > | > |代入される左辺値は||で指定するというので統一じゃだめなんでしょうか? > |もしかして構文解析が難しい? > > つーか、「||の右に来るそれはナニ?」と言う点であんまり統一感 > がないのでソノ気にならないです。逆に||を例外の右側に持ってく > るのは構文的につらいです(2項演算子と区別できない)。 rescue ScriptError do |err| ならば? でもそうするとこの場合は do を省略 不可になっちゃいますか。 -- そうだ 強気に ちょっと インチキに☆彡 中田 "Bugるくらいがちょうどいいかも;-)" 伸悦