From: gotoken@... (GOTO Kentaro) Date: 2000-02-10T16:57:38+09:00 Subject: [ruby-dev:9186] Re: site_ruby ごとけんです In message "[ruby-dev:9183] Re: site_ruby" on 00/02/10, Yukihiro Matsumoto writes: >|> > > だと思いますが、"." よりも File.dirname($0) が入ってくれた方が嬉しいよ >|> > >うな気もします。 >|> > >|> > それって -e のとき /tmp が入るから保安上ヤバくないですか?? >|> >|> 1.4.3 だと今でも -e はテンポラリ使うんでしたっけ? というか、スクリプト >|> ファイルが指定されたときだけにすれば問題はないんじゃないですか。 >| >| その線でパチってみました。1.5.2 と 1.4.3 用です。 > >これって保安上やばくないですか? > >いや、よくわかってないんですけど(あまり深く考える余裕が無い >らしい)、/tmpさえはずせば良いというものでもないような。 >便利そうなんで、安全と分かれば入れても良いんですけどね "." よりヤバいやも。危険の可能性として他人のディレクトリにあ るプログラムを直接実行する場合に予期せぬモノをロードする可能 性が考えられます。 -- gotoken