From: Wakou Aoyama Date: 1999-11-02T00:09:37+09:00 Subject: [ruby-dev:8200] Re: {literal}#[]= 青山です。 On Mon, 1 Nov 1999 18:06:46 +0900, gotoken@math.sci.hokudai.ac.jp (GOTO Kentaro) wrote: > やっぱり「代入」というのは紛らわしい呼び名ですね。えぐちさん > ほどのRubyはっかーが勘違いしてたんですから。 > > というわけで「=」を「命名演算子」と呼ぶことに一票。 ちなみに、alias を = の操作も出来るようにすると弊害は大きいでしょうか ね。ちょうど、先の alias "foo" foo というような記述ができたらどうかな、 という事ですが。 もしあまり弊害が無いようでしたら、これを採用すると、= はその別な記述の 仕方ですという説明が使えていいかもしれないかなと。 -- 青山 和光 Wakou Aoyama