From: gotoken@... (GOTO Kentaro) Date: 1999-11-01T18:06:46+09:00 Subject: [ruby-dev:8191] Re: {literal}#[]= In message "[ruby-dev:8189] Re: {literal}#[]=" on 99/11/01, EGUCHI Osamu writes: >matz> | 結局、『 ++ 演算子の議論』の変種って事ですね。 >matz> >matz> そういうことですね。Array#replaceはメソッドで実現できるが、 >matz> 代入はメソッドで実現できないということです。 > >代入がメソッドでないってそういう意味だったんですね。 やっぱり「代入」というのは紛らわしい呼び名ですね。えぐちさん ほどのRubyはっかーが勘違いしてたんですから。 というわけで「=」を「命名演算子」と呼ぶことに一票。 -- gotoken