From: Shin-ichiro Hara Date: 1999-08-17T01:57:04+09:00 Subject: [ruby-dev:7701] Re: [ruby-ext:00382] New coerce scheme 原です。 |... +!(other) の定義を |a, b = other.coerce(self, :+!); b + a; みたいにしておきます。 ここはやはり複雑過ぎますね。a + b も b +! a も知らなければ あきらめるのがシンプルでいい気がしてきました。 つまり反対演算があるなら、coerce は廃止したほうがいいので はないかと。