From: Shugo Maeda Date: 1999-05-24T12:01:55+09:00 Subject: [ruby-dev:6968] Re: RString#len 前田です。 At Mon, 24 May 1999 11:42:49 +0900, Yukihiro Matsumoto wrote: > |RString構造体のlenメンバについてなのですが、intに決め打ちではなく > |ポインタと同じ大きさの整数型にした方がよくないでしょうか。 > > 一度 size_t にしてたことがあったのですが,Rubyでは負のインデッ > クスを扱うことがあるので size_t が unsigned の処理系と馴染み > ません.妙にキャストが増えて嬉しくないです. > > intではなく,longにするというのはありえると思いますが. longとポインタのサイズが違う処理系がなければそれで問題ないと思う のですが、適当な名前でtypedefするというのはだめですか。 # 「適当な名前」が提示できれば採用すると言われそうな気がする(^_^; -- 前田 修吾