From: takagi@... (TAKAGI, Hiromitsu) Date: 1999-04-14T01:41:44+09:00 Subject: [ruby-dev:6598] Re: Queue#pop should be Queue#shift 話の流れを追っていないのですが、 Inaba Hiroto writes: > えっと、Queueクラスのメソッドがpushとpopなのは、ちょっと誤解の元ではな > いでしょうか? > 互換性もあるのでなくすわけにはいかないでしょうが、popにshiftという別名 > をつけてもらえませんか? StackとQueueを同じインターフェイスで使いたいこともあるという点では、 push, pop というのも悪くないきがします。 別名を付けるという点では、shiftというより、enqueue, dequeue ではないで しょうか。 あるいは、統一的に add, remove の方が良かったかも? 高木 浩光@逃避中 http://www.etl.go.jp/~takagi/ (工事中)