From: Inaba Hiroto Date: 1999-04-14T01:27:29+09:00 Subject: [ruby-dev:6597] Queue#pop should be Queue#shift 稲葉です。 えっと、Queueクラスのメソッドがpushとpopなのは、ちょっと誤解の元ではな いでしょうか? 互換性もあるのでなくすわけにはいかないでしょうが、popにshiftという別名 をつけてもらえませんか? #まつもとさんのスレッド版ExternalIteratorをcallccで書き直していて気が #付いたのですが。 -- 稲葉 浩人