From: matz@... (Yukihiro Matsumoto) Date: 1999-03-10T15:20:56+09:00 Subject: [ruby-dev:6177] Re: unpack まつもと ゆきひろです In message "[ruby-dev:6175] unpack" on 99/03/10, IKARASHI Akira writes: |適切な議論かどうかわからないのですが、template文字(?) |の個数と同じ大きさの配列を返したほうが、使い勝手が良く、 | "" を unpack した結果がそれぞれに入っているのが、 |合理的だと思います。 なんとなく分からないでもないです. 気になるのは「長さ」の定義が文字列を返すものの場合には「文字 列の長さ」であり,数値を返すものの場合には「数値の数」である 点です.つまり「C4」が「バイト4つ」であり,「CCCC」の省略で あるのに対して,「a4」は「4文字の文字列」であり,「aaaa」と は意味が異なる点です. この点も含めて,挙動を定義すべきでしょう.また,""から「C」 を取り出そうとした時の期待される値(nil? 0? それ以外?)につい ても検討しないといけませんね. 現状が使いにくいという五十嵐さんの意見には賛成です.で,変え ることを前提としてどうするのが本当に使いやすいかについて話し 合いましょう. |ですから、個数をどうするかはともかくとして、少なくとも |Stringを返す「文字」と、String以外を返す「文字」で振る舞いが |異なるという状態は修正したほうが良いのではないでしょうか? これらは違うものなんで振る舞いが違うのは当然なんですね.ただ, 現状の「違い方」が使いにくいだけで. まつもと ゆきひろ /:|)