From: Inaba Hiroto Date: 1999-04-14T02:57:23+09:00 Subject: [ruby-dev:6601] Re: Queue#pop should be Queue#shift 稲葉です。 TAKAGI, Hiromitsu wrote: > > 話の流れを追っていないのですが、 > > Inaba Hiroto writes: > > えっと、Queueクラスのメソッドがpushとpopなのは、ちょっと誤解の元ではな > > いでしょうか? > > 互換性もあるのでなくすわけにはいかないでしょうが、popにshiftという別名 > > をつけてもらえませんか? > > StackとQueueを同じインターフェイスで使いたいこともあるという点では、 > push, pop というのも悪くないきがします。 はい、Queueクラスに限れば悪くないんですが、Arrayクラスにpop,push, shift,unshiftというPerlからきたmethodがあって、popとpushでスタック、 pushとshift(またはunshiftとpop)でキューになるということになっている ので、誤解の元といいました。 > 別名を付けるという点では、shiftというより、enqueue, dequeue ではないで > しょうか。 それでもいいです。ちょっと長いかな?enq、deqという名前でもいいです。 -- 稲葉 浩人