From: SASADA Koichi Date: 2012-11-19T22:33:00+09:00 Subject: [ruby-dev:46543] Re: [ruby-cvs:44900] kosaki:r37730 (trunk): * thread.c, vm_core.h: big rename th to cur_th when works only (2012/11/19 22:15), SASADA Koichi wrote: >>>> >> > 理由は,他のソースコードにもこの名前規則(th == current thread)を使って >>>> >> > いるからです.あと,このケースを書くことが最も多いので,短い名前を利用し >>>> >> > たいです. >> > 短くしたいというなら curかなあ。thはありえないと思います。説明が必要な >> > 変数の命名規則というのがどうも。変数名って説明するためにあるんでしょ。 >> > という感覚 >  私としては,現状での全体の整合性を取りたいので,th で統一したいと思い > ます.  改めて見直してみたんですが,th を使っていても current thread のものが まだ thread.c に混ざっているようです.実は,見ていて cur_th にしているの もわかりやすいなぁ,とも思ってしまったのですが,任意の thread を受け取 る,というものを target_th というような別の名前にしたほうが,作業量を少 なく全体を統一出来るのではないかとも感じました(すでに,他のところではそ の混乱があります).  現状が,th という引数名で2つの意味がありわかりづらい,というのは同意し ますので,target_th というような名前にするのが良いのではないかと思います.  rb_thread_t *th = GET_THREAD() というイディオムが至る所にあるので,この辺がそもそも thread って何だよ, とか突っ込みが入りそうなところです.とりあえず,現状だとまだ混乱している ので,一度リセットして,ある程度まとめてから作業に取りかかるのがいいん じゃないかと思います.それが 2.0 に入れるべき作業であるかどうかはわかり ません.  混乱をなくすという観点から,thread.c に関しては,複数のスレッドが入り 乱れるので,th という変数名を禁止する,という方針がいいのかもしれませ ん.とりあえず,現状の th を任意のスレッドを受け取る,という意味で使って いるのは受け入れがたいです. -- // SASADA Koichi at atdot dot net