From: SASADA Koichi Date: 2012-11-19T22:15:26+09:00 Subject: [ruby-dev:46542] Re: [ruby-cvs:44900] kosaki:r37730 (trunk): * thread.c, vm_core.h: big rename th to cur_th when works only (2012/11/19 21:57), KOSAKI Motohiro wrote: >> > この観点でいうと,任意のスレッドを指定する名前を th から別の引数名に >> > し,th をカレントスレッドを渡す,という意味で使うべきだと主張します(一 >> > 部,すでに target_th という名前を使っています). >> > >> > 理由は,他のソースコードにもこの名前規則(th == current thread)を使って >> > いるからです.あと,このケースを書くことが最も多いので,短い名前を利用し >> > たいです. > 短くしたいというなら curかなあ。thはありえないと思います。説明が必要な > 変数の命名規則というのがどうも。変数名って説明するためにあるんでしょ。 > という感覚  私としては,現状での全体の整合性を取りたいので,th で統一したいと思い ます. -- // SASADA Koichi at atdot dot net