From: KOSAKI Motohiro Date: 2012-11-19T21:57:48+09:00 Subject: [ruby-dev:46541] Re: [ruby-cvs:44900] kosaki:r37730 (trunk): * thread.c, vm_core.h: big rename th to cur_th when works only 2012/11/19 SASADA Koichi : > こういう変更を,理由の説明や事前の連絡無く行われると混乱します. > とりあえず revert して議論しませんか. ああ、すいません。最近のasync_errinfo まわりの変更のあと あまりにも可読性を破壊していたので、つかカッとなってやって しまいました。 > なお,私の立場を表明しておくと,私はこの変更に反対します. > > 推測するに,引数として任意のスレッドを撮るか,それとも current thread を > 意味しているかわからない,ということかと思います(先日聞いた).違ったら > 下記の意見は見当違いなのでご指摘ください. そのとおりです。 > この観点でいうと,任意のスレッドを指定する名前を th から別の引数名に > し,th をカレントスレッドを渡す,という意味で使うべきだと主張します(一 > 部,すでに target_th という名前を使っています). > > 理由は,他のソースコードにもこの名前規則(th == current thread)を使って > いるからです.あと,このケースを書くことが最も多いので,短い名前を利用し > たいです. 短くしたいというなら curかなあ。thはありえないと思います。説明が必要な 変数の命名規則というのがどうも。変数名って説明するためにあるんでしょ。 という感覚