From: "U.Nakamura" Date: 2011-06-10T14:58:43+09:00 Subject: [ruby-dev:43693] Re: test.rb for make run こんにちは、なかむら(う)です。 In message "[ruby-dev:43692] Re: test.rb for make run" on Jun.10,2011 14:34:07, wrote: > > あー、すみません、手元の変更が紛れ込んでいました。 > > というわけで、それがコミットされたのは間違いなくミスです。 > >  では,戻させて頂きます. あい、ありがとうございます。 > > なお、マクロTESTRUN_SCRIPTは長すぎるので、もっと短い名前にす > > ることを希望します。 > > 例えばRUNだけとか。 > >  その辺は(私は多分,default しか使わないので)お任せします. make RUN=foo.rb run だとなんかランランしすぎてるので、 make SCRIPT=foo.rb run で行こうかなあと思います。 SCRIPTとかいう一般的なマクロ名をここで使っていいのか、という 意見はおそらくあると思いますが、実際問題として今使ってないし 近い将来使う気もしないので、問題ないじゃん、ということにしま す。 # もしもっと有用な用途で名前がかぶりそうならこっちが折れると # いう予定で。 建設的な異論がなければ来週にでもこれは変えます。 >  make runruby をよく使うので,make run を make runruby 相当にしてくれ, > という意見を聞きました. > >  make run 自体は,私が miniruby を弄るために作ったターゲットですが(VM > 弄ると,そもそも ruby 作れないため),最近は確かに ruby 自身でテストした > ほうがいいことも多そうなので,そのように変更しようと思います. 大賛成。 それでは。 -- U.Nakamura