From: Takahiro Kambe Date: 2010-12-03T09:39:03+09:00 Subject: [ruby-dev:42676] Re: [Ruby 1.9-Bug#4110] ホスト名の先頭が数字であるとき、WEBrickのテストでErrorが出る In message <4cf7d921e329c_5e69b630e7e65d@redmine.ruby-lang.org> on Fri, 3 Dec 2010 02:36:34 +0900, Yui NARUSE wrote: > RFC 2396 では以下の通りだったけれど、 > hostport = host [ ":" port ] > host = hostname | IPv4address > hostname = *( domainlabel "." ) toplabel [ "." ] > domainlabel = alphanum | alphanum *( alphanum | "-" ) alphanum > toplabel = alpha | alpha *( alphanum | "-" ) alphanum > RFC 3986 で変わって許されるようになったんですね。とりあえず対処を入れます。 > authority = [ userinfo "@" ] host [ ":" port ] > host = IP-literal / IPv4address / reg-name > reg-name = *( unreserved / pct-encoded / sub-delims ) 元々、DNS的ドメイン名は RFC-1123 で「ホスト名の最初が英文字だけ」とい う制限を外しているので、 RFC-2936 の定義がそれを失念してたという感じじゃ ないでしょうか。変わったというより、誤りを正したという感じで。 -- 神戸 隆博 (かんべ たかひろ) at 仕事場