From: SASADA Koichi Date: 2010-04-01T02:28:21+09:00 Subject: [ruby-dev:40896] Re: [Feature #3065] [TypedData] という名前について  ささだです. (2010/04/01 2:16), Tadashi Saito wrote:: >>> つまり「自分でメモリ使用量を知っているRData」を作りたかったのに、 >>> 名前から伝わる印象はそれと異なり、「型の把握が簡単なRData」になって >>> しまっています。 >> > (snip) >> 従来は dfree のポインタを比較するという dirty hack で型チェック >> していたところが、rb_data_type_t の比較になったのは TypedData の >> 重要な功績だと思います。 > > これは同意します。しかし、それを主眼に新しい構造体やAPIを作ったとは、自分は > 思えなかったのです。つまり、良い副作用があるとは思いますが、その副作用自身を > 名前にするべきではないと思います。あくまで名前は、作った目的に合わせて付けた > 方が良いでしょう。  残念ながら,それが主眼です.  メモリ関係が副作用です. -- // SASADA Koichi at atdot dot net