From: SASADA Koichi Date: 2010-04-01T02:26:54+09:00 Subject: [ruby-dev:40895] Re: [Feature #3069] [TypedData] 関連APIの名前が不揃い  ささだです. (2010/04/01 1:54), Tadashi Saito wrote:: > 1.9.2で新設される、RTypedData関連の関数・マクロ群の名前が > 不揃いで、ちょっと分かりにくいと感じていて、お願いに来ました。 > > まず、 struct RTypedData があるわけですが、Rubyの慣習でいけば、 > 小文字に直した時は typed_data になるか、アンダースコアがなくて > typeddataになるなどが期待されると思います。これはどちらにせよ、 > 統一されるべきでしょう。加えて、語順が変わることは自然でない > とも感じます。 > > ところが > rb_typeddata_is_kind_of() > では間にアンダースコアが入ってないと思いきや > RUBY_TYPED_DEFAULT_FREE > ではアンダースコアが(DATAが省略されて)入っています。また > rb_data_typed_object_alloc() > という、単語が前後入れ替わった関数があったりもします > > もう少し統一していただけると、思いだしやすかったり、 > 類推しやすかったりすると思うのですが、いかがでしょうか。 > > とりあえず、typedが入っている三つの関数 > > rb_check_typeddata > rb_data_typed_object_alloc > rb_typeddata_is_kind_of > > について考えたのですが、「RTypedDataに着目した関数である」ので > > rb_typeddata_check > rb_typeddata_object_alloc > rb_typeddata_is_kind_of > > というふうに揃えるのはいかがでしょうか。  もっと不揃いな API は沢山あるよなぁ,と思いつつ,そうですねぇ.そうし ましょうかねぇ.実は,それぞれ何をするんだか覚えてないので,少し考えま す.他にも意見があるといいなぁ,と思います. -- // SASADA Koichi at atdot dot net