From: Tadashi Saito Date: 2010-04-01T00:30:38+09:00 Subject: [ruby-dev:40884] [Feature #3065] [TypedData] という名前について Feature #3065: [TypedData] という名前について http://redmine.ruby-lang.org/issues/show/3065 起票者: Tadashi Saito ステータス: Open, 優先度: Normal 斎藤と申します。 1.9.2に取り込まれないであろうことは百二十くらい承知で、TypedDataに 付いての疑問点をいくつか書かせていただきます。 trunkには、RDataの代わりに(なりそうな)RTypedDataが導入されましたが、 これは良くない名前ではないでしょうか。 まず、新しい構造体には「Type」という単語が追加されたわけですが、これは struct RTypedDataのメンバーであるtypeから察するに、rb_data_type_tの 事を指し、それによって型をまとめてチェックできる(rb_typeddata_is_kind_of) という意味になると思います。 しかしささださんと先日Twitter上で話したところ、これを作った主な動機は メモリ使用状況の正確な把握にある、つまりrb_data_type_tとして追加で dsize関数ができたことにあるようでした。(間違っていたらすみません) つまり「自分でメモリ使用量を知っているRData」を作りたかったのに、 名前から伝わる印象はそれと異なり、「型の把握が簡単なRData」になって しまっています。 # 「Typed」にもし「自分の資源消費量を知っている」という意味があれば、 # 問題ないと思います。その場合、単に自分の知識不足ので、Closeして # ください。ごめんなさい。 自分の今までのコンピュータの知識では、「型」という言葉には、その オブジェクトが現実のコンピュータでどれほど資源を食っているか、という 意味では使われないと思います。もしそうならば、名が体を表していないの で、良くない名前だと思います。 メモリサイズが測れるということを伝えるのならば、シンプルに「RSizedData」 とかの方が、分かりやすくて良いと思います。 という、API変更の提案でした。誤解がたくさんあるかもしれませんが、どうぞ よろしくお願いします。 ---------------------------------------- http://redmine.ruby-lang.org