From: KOSAKI Motohiro Date: 2009-12-01T10:29:10+09:00 Subject: [ruby-dev:39820] Re: RbConfig.rubybin > At Mon, 30 Nov 2009 19:28:39 +0900, > KOSAKI Motohiro wrote: > > > In article <20091123.123808.1122146273169400964.kou@cozmixng.org>, > > > Kouhei Sutou writes: > > > > > > > ただ、メソッド名はRbConfig.rubyの方がよい気がします。 > > > > > > ちょっとチャレンジな気がしますが、それもいいかも知れませんねぇ。 > > > > > > そうするとすると、こうでしょうか。 > > > > 反対に投票します。 > > "ruby" の4文字からパス名だと類推できる気がしないからです。 > >  ENV['RUBY'] とも呼応するし、何より「ruby」とハードコードする > 代わりに使うものなので推測は容易だと思います。私は賛成です。 おや、予想外に多数の反論が。 僕1人しか、違和感を感じた人はいなかったようなので、取り下げます