From: Kouhei Sutou Date: 2009-11-30T21:39:52+09:00 Subject: [ruby-dev:39816] Re: RbConfig.rubybin 須藤です。 In <20091130192237.5C02.A69D9226@jp.fujitsu.com> "[ruby-dev:39815] Re: RbConfig.rubybin" on Mon, 30 Nov 2009 19:28:39 +0900, KOSAKI Motohiro wrote: >> > ただ、メソッド名はRbConfig.rubyの方がよい気がします。 >> >> ちょっとチャレンジな気がしますが、それもいいかも知れませんねぇ。 >> >> そうするとすると、こうでしょうか。 > > 反対に投票します。 > "ruby" の4文字からパス名だと類推できる気がしないからです。 > > そもそも、4文字にまで縮めないといけないほど頻繁に使われるものか疑問です。 私がrubybinよりrubyの方がよいと思うのは、よく使うから短くした いという理由ではなくて、rubyとbinがくっついていたり、binはバ イナリの略?とかという理由でrubybinがわかりづらかったからで す。 ruby_pathとかであれば、それでもよいと思っています。 蛇足ですが、パス名を表す名前としてコマンドと同じ名前を使うの は、よくあるパターンだと思っていました。Rubyのconfigureで も--with-baserubyというオプションがありますが、 --with-baseruby=RUBY use RUBY as baseruby; RUBY is the pathname of ruby というように、コマンドのパス名の変数名としてRUBYを使っていま す。 > ruby_interpreter_path_super_galactica_magnum とかやたら長い名前だとしても、 > APIリファレンス一発で引けるなら誰もこまらないような。 名前を考えることは諦めない方がよいと思うのですが。。。